EngagementHQ Public Facing Sites - Degraded Performance

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 00:00 MDT

Update

The platform remains stable following the implemented fixes. Granicus Engineering teams continue to actively monitor the environment to ensure ongoing performance and reliability.
Posted Mar 31, 2026 - 08:53 MDT

Update

We are continuing to monitor for any further issues.
Posted Mar 31, 2026 - 00:19 MDT

Update

Granicus Engineering teams have implemented a temporary fix and are currently continuing with stabilisation efforts and ongoing investigation into the root cause investigation with intermittent performance degradation on the infrastructure to ensure continued stability and performance.

Our teams are working on this issue as priority and further updates will be provided as soon as possible.
Posted Mar 31, 2026 - 00:18 MDT

Update

Granicus Engineering teams have implemented a temporary fix and are currently continuing with stabilization efforts and ongoing investigation into the root cause investigation with intermittent performance degradation on the infrastructure to ensure continued stability and performance.

Our teams are working on this issue as priority and further updates will be provided as soon as possible.
Posted Mar 30, 2026 - 01:49 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 29, 2026 - 19:53 MDT

Update

Our engineers are continuing investigate the root cause and working to resolve the issue. We will provide updates as more information comes to hand.
Posted Mar 29, 2026 - 18:42 MDT

Investigating

Granicus Engineering teams are currently investigating an issue where some customer sites are not loading or seeing degraded performance. Our teams are working on this issue as priority and further updates will be provided as soon as possible.
Product: EngagementHQ AU & NZ Regions

Updates on this issue will continue to be provided on status.granicus.com, for other issues or questions please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted Mar 29, 2026 - 18:07 MDT
This incident affected: govDelivery - EngagementHQ (EHQ - Australia).