We have identified the source of the recent Legistar performance degradation and have observed significant improvement in platform performance. Multiple agencies have confirmed that latency and freezing symptoms have been resolved or returned to normal operation following remediation efforts. Our teams continue to actively monitor the environment and validate stability across impacted customers. At this time, service performance appears stable, and we will remain in a monitoring phase before confirming full resolution of the incident
Posted Aug 26, 2026 - 15:20 MDT
Identified
We have identified the source of the recent Legistar performance degradation and are seeing service performance improve across the environment. Multiple agencies have confirmed that latency and freezing symptoms have significantly improved or returned to normal. Our teams continue to monitor platform performance and validate stability across affected customers. We will continue to provide updates and will resolve this incident once monitoring confirms sustained normal operation.
Posted Aug 26, 2026 - 14:19 MDT
Investigating
We are investigating reports of performance issues affecting Legistar, including slowness, freezing, and increased latency for some users. Our teams have identified multiple reports and are actively working to determine the cause.
We have engaged Engineering and Support teams, are reviewing system performance data, and continue to monitor the environment closely. We will provide further updates as more information becomes available.
Posted Aug 26, 2026 - 10:39 MDT
This incident affects: govMeetings - Live Video, Legislative and Agenda (Legistar).