Granicus Issue Notification: Gov Delivery - Communication Cloud (UK)

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted May 26, 2026 - 07:04 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2026 - 06:05 MDT

Update

We are continuing to investigate this issue.
Posted May 26, 2026 - 05:01 MDT

Investigating

11:45 GMT
Granicus Engineering teams are currently investigating an issue impacting GovDelivery – Communications Cloud (UK). Our teams are treating this as a priority, and further updates will be provided as soon as possible.

Product: GovDelivery – Communications Cloud (UK)

Updates on this issue will continue to be provided on Status.Granicus.com. For other issues or questions, please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted May 26, 2026 - 04:59 MDT
This incident affected: govDelivery - Communications (Communications Cloud).