Granicus has implemented a Legistar SSO Login Fix – Action Is Required **Important** These actions only apply to Legistar SSO customers who have had trouble logging into Legistar.
To apply the fix for the Legistar SSO login issue:
1 - Close Legistar. 2 - Delete the L5 folder from your Legistar program directory (usually on your C:\Granicus\Legistar5\ folder. If it is installed in a different directory, you can locate it by right clicking on the Legistar program shortcut, choose 'Properties' and reference the path in the 'Target' line.) 3 - Restart Legistar.
This will download the updated files and restore SSO login functionality.
Granicus Engineers have identified a fix for the Legistar SSO login issue and are working to push a fix overnight 8/25/25.
Legistar users who login via username and password should still be able to login via the Forms Authentication option. If you need assistance with logging in via this method, please reach out to your Legistar Admin or Granicus support.
Posted Aug 25, 2025 - 12:00 MDT
Update
While we are continuing to investigate, this impacts only for US & Canada clients using the SSO login only
Posted Aug 25, 2025 - 09:10 MDT
Investigating
Granicus Engineering teams are currently investigating an issue impacting govMeetings Legistar. Our teams are working on this issue as priority and further updates will be provided as soon as possible.
Product: govMeetings Legistar
Updates on this issue will continue to be provided on Status.Granicus.com, for other issues or questions please contact us at Support.Granicus.com.
Posted Aug 25, 2025 - 08:47 MDT
This incident affects: govMeetings - Live Video, Legislative and Agenda (Legistar).