Granicus Issue Notification: Indigov Service Disruption

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 12:20 MDT

Investigating

The Indigov platform is experiencing connectivity issues, causing some users to see 504 errors. Our engineering team is working to resolve this issue, and we will update this page as soon as we release a fix.
Posted Mar 18, 2026 - 10:32 MDT