Granicus Issue Notification: govMeetings MediaManager and Associated Applications

Incident Report for Granicus System

Monitoring

Granicus Engineers have implemented a fix for the MediaManager latency issues and have moved the issue status to Monitoring. If you are still having issues after refreshing your browser, please reach out to https://support.granicus.com/.
Posted Sep 02, 2025 - 15:31 MDT

Investigating

Granicus Engineering teams are currently investigating an issue impacting login and reliability of govMeetings MediaManager and applications that interface with MediaManager. Our teams are working on this issue as priority and further updates will be provided as soon as possible.

Product: govMeetings MediaManager, Legistar, Peak, iLegislate,

Updates on this issue will continue to be provided on Status.Granicus.com, for other issues or questions please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted Sep 02, 2025 - 10:29 MDT
This incident affects: govMeetings - Live Video, Legislative and Agenda (MediaManager, Archive Video, Legistar, Peak, Boards & Commissions, iLegislate).