Granicus Engineering continues to actively work on resolving the intermittent issue impacting InSite where some users may receive a "This document has been removed" error when attempting to access agendas, agenda packets, attachments, and supporting documents.
Since our last update, the team has made progress in identifying contributing factors and our engineering team remains engaged and we will continue to provide updates as we make further progress. We sincerely apologize for the inconvenience.. We understand the impact this has on public access to meeting materials and appreciate your patience as we work toward a permanent resolution.
In the meantime, affected users can restore access by clearing their browser cache and fully restarting their browser. If the issue reoccurs, repeating this step should allow temporary access. We also recommend using Firefox as an alternative browser, which has not been impacted by this issue.
Posted Jul 30, 2026 - 10:04 MDT
Update
Granicus Engineering continues to investigate intermittent issues impacting InSite where some users may receive a "This document has been removed" error when attempting to access agendas, agenda packets, attachments, and supporting documents.
During the investigation, the team reviewed application, browser, and infrastructure activity and implemented mitigations targeting elevated automated traffic patterns observed on affected endpoints. While some users have reported improved results, the issue remains intermittent and additional reports are still being received.
As a temporary workaround, affected users may be able to restore access by clearing their browser cache and restarting their browser. Granicus Engineering continues to actively investigate the root cause and monitor platform behavior.
Further updates will be provided as they become available.
Posted Jul 29, 2026 - 17:06 MDT
Investigating
Granicus Engineering is currently investigating an issue impacting the InSite platform where some users may receive a "This document has been removed" error when attempting to access agendas, agenda packets, and supporting documents. The team is actively working to identify the cause and restore normal functionality. Further updates will be provided as they become available.
Thank you, Granicus Customer Support
Posted Jul 29, 2026 - 10:31 MDT
This incident affects: govMeetings - Live Video, Legislative and Agenda (InSite).