Granicus Issue Notification: Custom Profile Registrations issue
Incident Report for Granicus System
Resolved
This issue has been resolved and all systems are operating normally.

Issue Summary:
We have established that a patch is not required for this issue. The resolution is as follows:
1. Open your site’s custom profile within the Forms Designer.
2. Navigate to the Form’s settings page and open the ‘Submissions’ tab.
3. Disable the ‘Show Submissions Message’ option.

The issue was introduced by the HTML Injection fix that went out in Release 473.

Only Custom Profile Registration Processes that have the option to Show Submission Message ticked were affected.

Showing Submission Message on Profile Registration Processes is not recommended best practice. The better option being to summarise the information submitted by the user in the last stage before submission so that the user has an opportunity to correct any mistakes.

The problem was not picked up by our testing because the custom profile registration used by QA follows our best practice recommendations and therefore did not have the Show Submission Message box ticked


Product: govService UK

We apologize for any inconvenience this service issue may have caused and thank you for your patience.

If you have any questions or would like more information about this issue, please contact us at Support@granicus.com.

Thank you,
Granicus Customer Support
Posted Apr 09, 2021 - 09:36 MDT
Monitoring
Issue Update: We have identified the root cause of this issue and have established a temporary solution which can be used now whilst the root cause is patched. The affected customers have been contacted directly via their Support Tickets
Product: govService

If you have any questions or would like more information about this issue, please contact us at Support@granicus.com.

Thank you,
Granicus Customer Support
Posted Apr 09, 2021 - 05:12 MDT
Investigating
Granicus is currently experiencing a client-impacting service issue.

Issue Summary: We are aware there is an issue with custom profile registrations and is currently looking into this
Product: govService UK

If you have any questions or would like more information about this issue, please contact us at Support@granicus.com.

Thank you,
Granicus Customer Support
Posted Apr 09, 2021 - 02:59 MDT
This incident affected: govService (govService U.K.).