The email delivery issue affecting govService (Firmstep) customers sending to Microsoft-hosted mailboxes (Outlook / Microsoft 365) has been fully resolved. Normal service has been confirmed across all affected customers. We apologise for any inconvenience caused and thank you for your patience.
Posted Sep 04, 2026 - 10:31 MDT
Monitoring
Our email delivery provider has confirmed that the underlying issue affecting deliveries to Microsoft-hosted mailboxes has been resolved. Email delivery is now functioning normally; however, previously deferred emails are being reprocessed and will be delivered progressively. We will continue to monitor service stability and provide a final update upon confirmed full resolution. We apologise for any inconvenience caused.
Posted Sep 04, 2026 - 07:09 MDT
Update
Our teams are observing improved email delivery success rates to Outlook and Microsoft 365 recipients, indicating that service recovery is underway. We remain engaged with our email delivery provider and are closely monitoring their progress while continuing to assess the impact to customers. Further updates will be provided as additional information becomes available.
Posted Sep 04, 2026 - 06:50 MDT
Identified
Update: Granicus Engineering is actively working with our email delivery provider to investigate an issue affecting emails sent from the govService (Firmstep) platform to Outlook and Microsoft 365 recipients. The provider has advised that they are aware of a broader issue impacting deliveries to Microsoft-hosted mailboxes and are monitoring the situation closely. We will continue to provide updates as additional information becomes available.
Posted Sep 04, 2026 - 06:08 MDT
Investigating
RUN - 143492 INVESTIGATING
Incident Description: Granicus Engineering is currently investigating an issue impacting email delivery from the govService (Firmstep) platform for some customers. As a result, some emails sent from the platform to Microsoft-hosted email accounts (including Outlook and Microsoft 365) may not be delivered as expected.
Impacted Locations, number of users: 3 (UK)
Current Incident Status: Open
Priority: Severity 2
Issue Reported By: Customer
Date / Time Reported: 8/27/2026 10.47 AM UK time
Date / Time Incident Reported as RUN: 08/27/2026 1.27 PM UK time
Incident Manager at Support: Vishwas Prasad
Other Parties involved: Product Engineering
Next Update Due: 08/27/2026 3.30 PM UK time
Posted Sep 04, 2026 - 05:49 MDT
This incident affected: govService (govService U.K.).