Granicus Issue Notification: GovRecords

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 03:57 MDT

Investigating

Granicus Engineering teams are currently investigating an issue impacting GovRecords eAccept. Our teams are working on this issue as priority and further updates will be provided as soon as possible.

Product: GovRecords eAccept

Updates on this issue will continue to be provided on support.granicus.com, for other issues or questions, please contact us at support.granicus.com.
Posted Mar 26, 2025 - 03:42 MDT