Granicus Issue Notification: govService Firmstep - Password Reset Email Delay
Incident Report for Granicus System
Resolved
This incident has now been resolved.

Please be advised that any citizens who have requested a password reset email whilst this incident has been on going but have not received one, will need to request a new password reset email.

We apologise for any inconvenience caused and thank you for your patience whilst we have worked to resolve this issue.
Posted Sep 05, 2024 - 04:48 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 02:30 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2024 - 01:31 MDT
Investigating
Granicus Engineering teams are currently investigating an issue affecting a subset of customers experiencing email delays when requesting password resets via the Firmstep Customer Portal. Our teams are working on this issue as priority and further updates will be provided as soon as possible.

Product: govService Password Reset Emails

Updates on this issue will continue to be provided on status.granicus.com, for other issues or questions please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted Sep 04, 2024 - 12:52 MDT
This incident affected: govService (govService U.K.).