Granicus Issue Notification: govDelivery Communications Cloud

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted May 11, 2026 - 19:15 MDT

Monitoring

We have applied fixes to our environment that have successfully resolved the issue. We apologize for any inconvenience this may have caused. If you have any additional questions or experience further issues, please contact us at support.granicus.com.
Posted May 11, 2026 - 16:36 MDT

Update

A fix has been implemented and service performance continues to improve.
We apologize for any inconvenience and thank you for your patience.
Posted May 11, 2026 - 16:12 MDT

Update

We are continuing to investigate this issue.
Posted May 11, 2026 - 15:30 MDT

Update

We’re investigating an issue with email bulletin delays affecting a subset of customers. Some messages may be delayed, but our teams are actively working to restore normal processing.
Posted May 11, 2026 - 15:26 MDT

Investigating

Granicus Engineering teams are currently investigating an issue impacting govDelivery Communications Cloud. Our teams are working on this issue as priority and further updates will be provided as soon as possible.

Product: govDelivery Communications Cloud

Updates on this issue will continue to be provided on Status.Granicus.com, for other issues or questions please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted May 11, 2026 - 14:41 MDT
This incident affected: govDelivery - Communications (Communications Cloud).