Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 26, 2026 - 21:00 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 26, 2026 - 17:11 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 26, 2026 - 15:38 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 26, 2026 - 15:37 MDT
Scheduled
Granicus is performing emergency infrastructure maintenance to address a hardware issue identified within the hosting environment supporting govMeetings services. Start Time: August 26, 2026, 9:00 PM CT End Time: August 26, 2026, 9:30 PM CT
During this maintenance window, customers may experience intermittent access issues or service interruptions affecting: Swagit Live Video Swagit Archive Video Video Streaming Services
This maintenance is necessary to complete infrastructure remediation and ensure platform stability following a hardware issue identified earlier today. We appreciate your patience and understanding as we work to maintain the reliability of our services.
Posted Aug 26, 2026 - 15:34 MDT
This scheduled maintenance affected: govMeetings - Live Video, Legislative and Agenda (Live Video, Archive Video, Swagit).