Granicus Issue Notification: GovService - Firmstep UK

Incident Report for Granicus System

Update

The platform continues to operate normally with no impact to new submissions.
Our Technical Support Team is continuing to contact all impacted customers with specific details and available recovery options. Our Engineering team has made significant progress on a solution.
We sincerely apologise for the inconvenience caused and appreciate your continued patience as we work toward a complete resolution for all affected customers.
Posted Jun 12, 2026 - 11:33 MDT

Update

The platform continues to operate normally with no impact to new submissions.

Our Technical Support Team has begun contacting impacted customers directly with specific details of the affected integrations and available recovery options. If you have been impacted, you will receive communication from our team.

We understand the disruption this has caused and sincerely apologies for the inconvenience. We appreciate your continued patience as we work toward a complete resolution for all affected customers.
Posted Jun 11, 2026 - 12:02 MDT

Update

The platform continues to operate normally with no impact to new submissions.
Our Technical Support Team has begun contacting impacted customers directly with specific details of the affected integrations and available recovery options. If you have been impacted, you will receive communication from our team.
We understand the disruption this has caused and sincerely apologise for the inconvenience. We appreciate your continued patience as we work toward a complete resolution for all affected customers.
Posted Jun 11, 2026 - 11:32 MDT

Update

The platform remains stable and fully operational for all new submissions.
Integrations running on the submission and creation stages of processes submitted between approximately 4:00 AM and 2:00 PM BST on 10th June may not have completed their downstream execution as expected.
Granicus engineering team is finalising the detailed per-customer impact assessment and expects to have this completed today.
Our Technical Support Team will begin contacting impacted customers directly today with specific details of the affected submissions and available recovery options.
We sincerely apologise for the inconvenience caused and appreciate your continued patience.
Posted Jun 11, 2026 - 07:15 MDT

Monitoring

Our engineering team has identified the root cause and successfully contained the issue. As of now, all new submissions are processing correctly, and the platform is stable and fully functional.

Our ongoing analysis indicates that some submissions created prior to the fix may not have completed their downstream integrations as expected. These impacted submissions are currently being assessed in detail and our Technical Support Team will contact any impacted customers tomorrow to assist with recovery of any missing integrations.

We sincerely apologise for the inconvenience caused and appreciate your patience and understanding as we work toward a complete resolution for impacted customers.
Posted Jun 10, 2026 - 11:06 MDT

Update

Granicus Engineering team has identified the root cause of the integration failures and has successfully contained the issue. New submissions are now processing as expected, and the platform is stable and fully operational.
Our teams are continuing to review the previously impacted integrations and submissions to assess their status and determine appropriate recovery actions. We will provide further updates as this work progresses.
We sincerely apologize for any inconvenience this incident may have caused and appreciate your patience and understanding.
Posted Jun 10, 2026 - 09:28 MDT

Identified

Following the earlier mitigation, we have identified additional issues impacting some integrations.
The Granicus Engineering team is actively investigating these findings and working on further corrective actions to restore full service.
We will provide an update shortly. We apologise for the continued disruption and appreciate your patience.
Posted Jun 10, 2026 - 07:58 MDT

Monitoring

12:20 GMT
The Granicus Engineering team has identified and implemented corrective actions to mitigate the cause of the issue.

Support teams are actively engaged to resolve the integrations that had already failed to achieve full service recovery.
We will share the next update shortly. We apologize for the inconvenience and appreciate your patience and cooperation.
Posted Jun 10, 2026 - 05:25 MDT

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 04:38 MDT

Investigating

11:30 GMT
The Granicus Engineering team is investigating issues with Database & Email Integrations on Firmstep UK. Support teams are actively engaged on this incident.

We will share the next update shortly. We apologise for the inconvenience and appreciate your patience and cooperation.
Posted Jun 10, 2026 - 04:37 MDT
This incident affects: govService (govService U.K.).