Granicus Issue Notification: Emails to swagit.com returning to sender.

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 19:11 MST

Investigating

Granicus Engineering teams are currently investigating an issue with emails sent to @swagit.com.

If you are having issues with contacting a Swagit department directly please call 1-800-573-3160, use the Granicus support portal at support.granicus.com/s/login/ or send an email to support@granicus.com indicating your request is for the Swagit team.

Product: govMeetings Swagit

Updates on this issue will continue to be provided on Status.Granicus.com, for other issues or questions please contact us at Support.Granicus.com.
Posted Mar 05, 2026 - 16:43 MST