Granicus Issue Notification: Simpleview CRM

Incident Report for Granicus System

Resolved

All affected Simpleview CRM sites have been restored to full service. Our engineering teams will continue to monitor for stability. We sincerely apologize for any inconvenience caused and appreciate your patience during this incident.
Posted Jul 24, 2026 - 10:30 MDT

Monitoring

Mitigation efforts continue and the majority of affected Simpleview CRM sites have been restored to normal operation. Our engineering teams are actively monitoring stability across the platform and continue working to bring the remaining affected sites back to full service. We will provide a further update once full recovery is confirmed.
Posted Jul 24, 2026 - 09:53 MDT

Identified

Engineering teams have identified the cause of the issue impacting a subset of Simpleview CRM sites. Mitigation actions are currently being implemented and teams are actively monitoring recovery. We will continue to provide updates as service restoration progresse
Posted Jul 24, 2026 - 08:54 MDT

Investigating

Granicus engineering teams are investigating an issue that affects a subset of Simpleview CRM sites. Our teams are engaged and working to identify the underlying cause and restore full service stability. We appreciate your patience and will provide further updates as additional information becomes available.
Posted Jul 24, 2026 - 08:29 MDT
This incident affected: Simpleview Products (CRM).