Granicus Issue Notification: govService Email Delay
Incident Report for Granicus System
Resolved
Granicus Engineering teams have identified and resolved this issue impacting govService Email deliveries. We apologise for any inconvenience this incident may have caused, and thank you for your patience.

If you have further questions or want more information about this resolved issue, please get in touch with us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted Mar 21, 2023 - 09:35 MDT
Monitoring
Granicus Engineering teams have identified and rectified the incident with email delays and arrival. Our teams will continue to monitor the incident until it is fully resolved.

We apologise for any inconvenience this service issue may have caused and thank you for your patience.

Thank you,
Granicus Customer Support
Posted Mar 20, 2023 - 11:18 MDT
Update
Granicus Engineering teams are still investigating this issue as a priority. We apologise for any inconvenience this issue may have caused, and thank you for your patience.

Thank you,
Granicus Customer Support
Posted Mar 20, 2023 - 08:09 MDT
Investigating
Granicus Engineering teams are currently investigating intermittent mailbox delay issues for UK-based customers. Our teams are prioritising this issue, and further updates will be provided as soon as possible.

Product: govService - Firmstep

Updates on this issue will continue to be provided on status.granicus.com. For other issues or questions, please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted Mar 20, 2023 - 07:01 MDT
This incident affected: govService (govService U.K.).