Simpleview CRM and CMS Image Upload Issues

Incident Report for Granicus System

Resolved

This issue has been resolved.
Posted Jun 02, 2026 - 13:42 MDT

Investigating

We are currently investigating an issue impacting Simpleview CRM and CMS products that is impacting the ability to upload images.

Our engineering teams are actively working to identify the root cause and restore full service as a priority. We will provide further updates as more information becomes available.
Posted Jun 02, 2026 - 13:32 MDT
This incident affected: Simpleview Products (CRM, CMS, CRM Extranet).