Granicus Issue Notification: govMeetings SpeakUp Degradation

Incident Report for Granicus System

Resolved

The issue impacting the availability of the govMeetings SpeakUp application has been resolved. The Granicus Engineering team implemented mitigation measures, and service has remained stable following monitoring and validation efforts.
We will continue to monitor the environment to ensure ongoing stability. We apologise for any inconvenience this issue may have caused and thank you for your patience.
Posted Jul 07, 2026 - 09:45 MDT

Identified

The Granicus Engineering team has identified the cause of the issue affecting the govMeetings SpeakUp application and is actively implementing mitigation measures. We are monitoring the environment closely to confirm service stability and will provide further updates as progress continues. Thank you for your patience.
Posted Jul 07, 2026 - 09:22 MDT

Update

The Granicus Engineering team continues to actively investigate the issue impacting the availability of the govMeetings SpeakUp application. Our teams have completed several mitigation and diagnostic activities and are currently performing deeper analysis to determine the source of the service instability.
We remain focused on restoring normal service as quickly as possible and will provide further updates as additional information becomes available. Thank you for your patience.
Posted Jul 07, 2026 - 08:14 MDT

Investigating

We are currently investigating an issue impacting the availability of the govMeetings SpeakUp application. Users may be experiencing issues accessing the service. The Granicus Engineering team is actively investigating the issue and working to restore normal service as quickly as possible.
We will provide further updates as more information becomes available. Thank you for your patience.
Posted Jul 07, 2026 - 07:21 MDT