GovQA slowness

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 18:10 MST

Investigating

We are experiencing database slowness that is impacting some customers. We will provide updates as they are available.
Posted Nov 12, 2025 - 10:10 MST
This incident affected: govService (GovQA).