Granicus Issue Notification: Simpleview CRM

Incident Report for Granicus System

Monitoring

We’ve applied updates to the application intended to address the issue and are actively monitoring performance to ensure the changes are having the desired effect. We’ll provide more information as soon as it becomes available.
Posted Jan 28, 2026 - 12:12 MST

Investigating

Granicus Engineering teams are currently investigating an issue with the Microsoft Outlook Toolbar add-in, which is currently experiencing an issue that prevents users from authenticating. Our Engineering team is actively working to identify and resolve the cause of this issue. We hope to have a resolution pushed soon.
Product: Simpleview CRM + Microsoft Integration Tool

Updates on this issue will continue to be provided on status.granicus.com, for other issues or questions please contact us at Support.Granicus.com.

Thank you,
Granicus Customer Support
Posted Jan 28, 2026 - 11:01 MST
This incident affects: Simpleview Products (CRM).