Granicus Issue Notification: Simpleview CRM

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 15:41 MDT

Investigating

We are currently experiencing intermittent outages and latency issues affecting a limited number of systems within the Simpleview CRM platform. Our engineering teams are actively investigating and working to restore functionality. We will continue to provide updates on this page as more information becomes available.
Posted Aug 20, 2025 - 10:12 MDT
This incident affected: Simpleview Products (CRM).