Simpleview CRM login and Economic Impact Calculator (EIC) functionality have been restored. Customers should now be able to access their CRM environments and use EIC-related features normally.
We apologize for the disruption and appreciate your patience while service was restored.
Posted Sep 09, 2026 - 09:55 MDT
Update
Login access to Simpleview CRM remains available. Economic Impact Calculator (EIC) functionality is still unavailable.
We are actively working with our provider to restore EIC services. We do not yet have an estimated time for full restoration and will provide another update within the next two hours, or sooner if additional information becomes available.
We apologize for the continued disruption and appreciate your patience.
Posted Sep 09, 2026 - 07:56 MDT
Identified
Granicus Engineering has implemented a workaround that restores login functionality for affected Simpleview CRM customers. Users should now be able to successfully access their CRM environments; however, an underlying Economic Impact Calculator services remain unavailable and EIC-related functionality continues to be impacted.
Our teams are actively working with the appropriate stakeholders to investigate the remaining EIC integration issue. We apologize for the disruption and appreciate your patience as we continue our efforts to fully restore service.
Posted Sep 09, 2026 - 07:16 MDT
Investigating
We are currently investigating an issue impacting service for Simpleview CRMs and integrations. Service is unavailable for a subset of CRM clients. Our teams are working on this issue as a priority and further updates will be provided as soon as possible.
Posted Sep 09, 2026 - 06:40 MDT
This incident affected: Simpleview Products (CRM).