Granicus Issue Notification: Simpleview CRM Service Disruption

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 15:45 MDT

Monitoring

A fix has been implemented by our datacenter team, and we are currently monitoring the service to ensure it remains fully operational.
Posted Mar 17, 2026 - 14:08 MDT

Identified

Our datacenter team has identified the root cause and is actively implementing a fix to restore service. We will share additional updates as soon as they are available.
Posted Mar 17, 2026 - 09:58 MDT

Update

We are currently working with our data warehouse team to restore service. This issue is affecting service for Simpleview CRM and FuturePace. We will provide updates as more information becomes available.
Posted Mar 17, 2026 - 09:17 MDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2026 - 08:59 MDT

Investigating

We are currently investigating an issue impacting service for Simpleview CRMs. Our teams are working on this issue as a priority and further updates will be provided as soon as possible.
Posted Mar 17, 2026 - 08:48 MDT
This incident affected: Simpleview Products (CRM, CRM Extranet, FuturePace).